Temporary Slowness in Fera App

Incident Report for Fera

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 11:56 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2025 - 16:50 EST

Investigating

We are currently experiencing slowness in our servers following the "Black Friday" weekend, which may affect app performance. Our team is actively working to resolve this issue and add more capacity to handle the load.
Posted Nov 27, 2025 - 09:43 EST
This incident affected: Fera Management Portal.