We’re currently experiencing server delay

Incident Report for Fera

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 07:11 EDT

Investigating

Mechants reported that widgets are not showing on live pages, orders are not updating automatically, and products are missing from orders. The issue is widespread and we are working with our server hosting to resolve everything soon.
Posted Sep 19, 2025 - 14:48 EDT
This incident affected: Fera APIs (Public API).