Maintenance in progress!

Incident Report for Fera

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 05:21 EDT

Identified

We’re currently upgrading our servers and enhancing security to better protect you and your customers.

Fera will be temporarily unavailable while we complete these improvements.

We appreciate your patience and will have everything back up as quickly as possible.
Posted Apr 22, 2026 - 14:24 EDT
This incident affected: Fera Management Portal.