Delays in Fera review imports

Incident Report for Fera

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 06:27 EST

Identified

Merchants may experience slower than usual review imports from external sources. We are actively working to resolve this issue as quickly as possible and will provide updates as soon as we have more information. We appreciate your patience and understanding. If you have any questions or concerns, please reach out to our support team.
Posted Feb 03, 2025 - 12:39 EST
This incident affected: Fera Management Portal.