Fera App Access Issue on Shopify

Incident Report for Fera

Resolved

This incident has been resolved.
Posted May 06, 2025 - 11:45 EDT

Identified

Merchants reported being unable to open the Fera app via Shopify Admin, affecting their ability to manage reviews. We're looking into the issue and trying to find a solution.

Temporary Workaround:
- Merchants could access Fera directly via app.fera.ai.
Posted Mar 25, 2025 - 07:15 EDT
This incident affected: Fera Management Portal.