Degraded performance
Incident Report for Fera
Resolved
Maintenance that affects the interface has been completed and everything should be back operational. We'll continue to keep an eye on things and update if needed.
Posted Jul 18, 2022 - 14:37 EDT
Identified
We're working on some old data cleanup procedures that might result in degraded performance until we've completed the updates.

This mostly only affects management of your Fera account and legacy features. It may also slow down review requests sent in the background or data syncs with eCommerce platforms.
Posted Jul 18, 2022 - 08:49 EDT
This incident affected: Fera Management Portal and Background Workers (Customer Messages, Syncs).