Temporary Slowness of Fera App

Incident Report for Fera

Monitoring

We have implemented multiple fixes, the overall speed of the app should be improved. Our engineers are working hard to return the full speed of the app soon.
Posted Nov 18, 2025 - 13:07 EST

Identified

Our team has identified the issue and is actively working with our service provider to resolve it as quickly as possible. We will keep you updated, and we truly appreciate your patience.
Posted Nov 17, 2025 - 11:36 EST

Investigating

We are currently experiencing slowness in our servers, which may affect app performance. Our team is actively working to resolve this issue as quickly as possible. Thank you for your patience.
Posted Nov 06, 2025 - 13:37 EST
This incident affects: Fera Management Portal.