Reviews Table Not Loading

Incident Report for Fera

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 07:07 EST

Investigating

We are currently experiencing slowness in our servers, which may affect reviews table performance. Our team is actively working to resolve this issue and add more capacity to handle the load.
Posted Jan 12, 2026 - 04:48 EST
This incident affected: Fera Management Portal.