Degraded performance

Incident Report for Fera

Resolved

This incident has been resolved.
Posted Jul 20, 2023 - 12:10 EDT

Identified

Performance should be much better now, but still investigating the issue and considering a fix.
Posted Jul 20, 2023 - 11:27 EDT

Investigating

We are currently investigating this issue.
Posted Jul 20, 2023 - 10:54 EDT
This incident affected: Fera Management Portal and Fera APIs (Public API, Private API).