Cloudflare Global Network experiencing issues

Incident Report for Fera

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:06 EST

Monitoring

Cloudflare Global Network has managed to find a solution, the app should be functional now. We are monitoring for more news.
Posted Nov 18, 2025 - 09:51 EST

Investigating

Cloudflare is experiencing an internal service degradation. Some services may be intermittently impacted. We are focused on restoring service. Most of the websites and services are running on cloudflare and it affected multiple services including Fera.

Read more: https://www.cloudflarestatus.com
Posted Nov 18, 2025 - 08:03 EST
This incident affected: Fera Management Portal.